Performance Degradation

Incident Report for netwrix

Resolved

This incident has been resolved. The team is continuing to investigate the root cause
Posted May 22, 2026 - 12:49 UTC

Investigating

We are currently investigating intermittent performance degradation in the US region.
Posted May 22, 2026 - 12:19 UTC
This incident affected: 1Secure - USA (Portal, Reporting).